Website downtime
Incident Report for MyCP
Update
UPDATE #2 - SSL issues being investigated. Please allow up to 24 hours for SSL security to be implemented on to the website. For now, play.myclubpenguin.com is SSL secure.
Posted Jan 14, 2023 - 07:50 UTC
Monitoring
A fix for the website has been implemented and the game is slowly coming back online. Will continue to monitor and make sure. Homepage will return shortly. #MyCP
Posted Jan 14, 2023 - 07:40 UTC
Investigating
My Club Penguin website and servers are currently down due to server issues. We are investigating these issues and hope to resolve it within 24 hours from now.
Posted Jan 13, 2023 - 06:11 UTC
This incident affects: Game Servers, Login Server, and Website.